Multipart image URL

Is Coranto not working properly for you? Here's where to ask for support help; for best results, follow these steps:
  • - Check your core/addon documentation for possible solutions
  • - Search these forums for similar problems that have already been solved
  • - If you're still stumped, check out THIS TOPIC, and post your question in this forum!!

Moderators: Spunkmeyer, Dale Ray, SrNupsen, Bluetooth, Jackanape

Multipart image URL

Postby ukracer » Wed Oct 11, 2006 2:13 pm

Hi

Here I am again.

tried everything I can and using the add on I can now up load an image to a folder so I see how it all works now. What i dont follow is the procedure for actually linking the image to the individual news item.

I have created a profile and news field but despite be being able to insert a link manually I can help but thinking this is now how it really works :)

I think my problem is a basic lack of understanding on how profiles, styles, newsitems and categories all fit together.

I have searched for documentation but I am eiter really thick of the concept is just going over teh top of my head.

My GUESS is that to make this work (Multipart image inclusion into my news item ) I need to add a command to the STYLE section but I can not find examples that fit the bill.

Sorry for being such a numpty.

Thanks for helping!
ukracer
 
Posts: 20
Joined: Sun Jan 02, 2005 10:06 pm

Postby Dale Ray » Wed Oct 11, 2006 4:10 pm

Assuming that you have these custom fields:

CustomField_yourPic - which is your upload field
CustomField_yourPicAltText - text for the image's alt tag

The image tag in your style should be:

<img src="<FilePath: CustomField_yourPic>" alt="<Field: CustomField_yourPicAltText">

This will insert the http path to the specific file in the File Upload field for the current item and your alt text.

If you want the image to be a clickable link you could use:

<a href="h**p://www.yourlinkhere/"><img src="<FilePath: CustomField_yourPic>" alt="<Field: CustomField_yourPicAltText"></a>

You can substitute another Coranto field for the path in the link if you wish.

<a href="<Field: CustomField_yourLink"><img src="<FilePath: CustomField_yourPic>" alt="<Field: CustomField_yourPicAltText"></a>

MultiPart Docs wrote:<FilePath: CustomField_X> The http path to the specific file in the File Upload field and current newsitem.
<FileSize: CustomField_X> The file size in Kb of the specific file in the File Upload field and current newsitem.
<ThumbPath: CustomField_X> The File Upload fields thumbnail you want to print the http path to. Only usefull if the 'Image Function' is enabled for the File Upload field.
Dale Ray
User avatar
Dale Ray
 
Posts: 1001
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana

getting rid of filename

Postby Gcampos » Tue Nov 21, 2006 7:49 pm

How do you get rid (omit) the filename?

http://www.bullfights.org/testing/index.shtml

The test page above shows the filename above the image, I would like to get rid of that, the style looks like this:

<p><b><font size="3" face="Arial">
<Field: Subject></font></b><br><br>
<Field: CustomField_Image_Uploads><br>
<img src="<FilePath: CustomField_Image_Uploads>"><br><br>
<font size="2" face="Arial">
<Field: Text></font></p>

Thanks,

Gerry
Gcampos
 
Posts: 31
Joined: Tue Jan 23, 2007 9:06 pm
Location: So Cal

Postby Von Snellfharer » Wed Nov 22, 2006 9:18 am

From this:
Code: Select all
<p><b><font size="3" face="Arial">
<Field: Subject></font></b><br><br>
<Field: CustomField_Image_Uploads><br>
<img src="<FilePath: CustomField_Image_Uploads>"><br><br>
<font size="2" face="Arial">
<Field: Text></font></p>


To this:

Code: Select all
<p><b><font size="3" face="Arial">
<Field: Subject></font></b><br><br>

Remove this field in your code -->> <Field: CustomField_Image_Uploads><br>

<img src="<FilePath: CustomField_Image_Uploads>"><br><br>
<font size="2" face="Arial">
<Field: Text></font></p>


This is just to point out where it is..
Von Snellfharer
________________________________________
last of the fullgrown men
User avatar
Von Snellfharer
 
Posts: 255
Joined: Fri Jun 21, 2002 8:03 am
Location: Semi arctic

Postby Gcampos » Wed Nov 22, 2006 10:53 pm

Von Snellfharer wrote:From this:
Code: Select all
<p><b><font size="3" face="Arial">
<Field: Subject></font></b><br><br>
<Field: CustomField_Image_Uploads><br>
<img src="<FilePath: CustomField_Image_Uploads>"><br><br>
<font size="2" face="Arial">
<Field: Text></font></p>


To this:

Code: Select all
<p><b><font size="3" face="Arial">
<Field: Subject></font></b><br><br>

Remove this field in your code -->> <Field: CustomField_Image_Uploads><br>

<img src="<FilePath: CustomField_Image_Uploads>"><br><br>
<font size="2" face="Arial">
<Field: Text></font></p>


This is just to point out where it is..


That didnt work, it removed the whole image from the page but left the image filename. I will try d rays post above see if that could fix it.

Thanks,

Gerry
Gcampos
 
Posts: 31
Joined: Tue Jan 23, 2007 9:06 pm
Location: So Cal

Postby GabeT » Thu Nov 23, 2006 3:30 pm

In your custom upload field settings have you double checked the upload Path to see if you have the correct Absolute path to your upload directory? Also, have you set the HTTP path too? I ran into these problems when I was setting up my coranto. I finally got it working when i noticed the HTTP path wasnt set to the correct directory on my server.
GabeT
 
Posts: 86
Joined: Thu Jan 11, 2007 12:35 am
Location: Albuquerque, NM

Postby Von Snellfharer » Thu Nov 23, 2006 3:37 pm

Look at the source of your page and see what is missing.
You might want to write:

Code: Select all
<img src="<FilePath: CustomField_Image_Uploads>/<Field: CustomField_Image>">


...or something similar, i usually farmat it like this:

Code: Select all
<img src="/the/path/<Field: CustomField_Image>">


As the path rarely differentiates
Von Snellfharer
________________________________________
last of the fullgrown men
User avatar
Von Snellfharer
 
Posts: 255
Joined: Fri Jun 21, 2002 8:03 am
Location: Semi arctic

Postby Gcampos » Tue Nov 28, 2006 4:59 am

Von Snellfharer wrote:Look at the source of your page and see what is missing.
You might want to write:

Code: Select all
<img src="<FilePath: CustomField_Image_Uploads>/<Field: CustomField_Image>">


...or something similar, i usually farmat it like this:

Code: Select all
<img src="/the/path/<Field: CustomField_Image>">


As the path rarely differentiates


Ok I got rid of it, seems the culprit was the:
Code: Select all
<Field: CustomField_Image_Uploads>

So I just deleted that from the style and the filename disappeared. The end result is:

Code: Select all
<table border="0" cellpadding="2" style="border-collapse: collapse" bordercolor="#111111" width="100%" id="AutoNumber1">
  <tr>
    <td width="50%"><p>
<Field: CustomField_Date><br><br>
<Field: Text><br><br></p></td>
    <td width="50%" valign="top"><img src="<FilePath: CustomField_Image_Uploads>"></td>
  </tr>
</table>


Thanks,

Gerry
Gcampos
 
Posts: 31
Joined: Tue Jan 23, 2007 9:06 pm
Location: So Cal


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests

cron