Add-on problem

Is Coranto not working properly for you? Here's where to ask for support help; for best results, follow these steps:
  • - Check your core/addon documentation for possible solutions
  • - Search these forums for similar problems that have already been solved
  • - If you're still stumped, check out THIS TOPIC, and post your question in this forum!!

Moderators: Spunkmeyer, Dale Ray, SrNupsen, Bluetooth, Jackanape

Add-on problem

Postby Stmcgill » Sat Jan 13, 2007 5:12 pm

Hi there

We have been using adding headlines for our three Coranto made news feeds for the past year and everything has worked fine... until we moved to a Linux server. For some reason the headlines no longer appear.

Our front page includes-

<TR><td class="alt1"><small><b>Windows Mobile 247</b></small><br>
<!--#include virtual="/news/WindowsMobileFeed.txt"-->
</td></tr>
<TR><td class="alt1"><small><b>More Mobile 247</b></small><br>
<!--#include virtual="/news/MoreMobileFeed.txt"-->
</td></tr>
</table>

WindowsMobileFeed.txt currently includes-

<a href="/wm.shtml#newsitemEEylylFyVpcAeVgOig"><small><small>15% off this weekend<br></small></small></a><a href="/wm.shtml#newsitemEEylyZuZppUNSsKDXT"><small><small>Check List Pro Desktop Version v5.0<br></small></small></a><a href="/wm.shtml#newsitemEEylyFAupFnkpbwQhR"><small><small>Done in 50 Seconds<br></small></small></a><a href="/wm.shtml#newsitemEEylyEEluVVobGNLxT"><small><small>Iphone copycats<br></small></small></a>

and MoreMobileFeed.txt has-

<a href="/moremob.shtml#newsitemEEylyZuVlpmGJFcwFd"><small><small>MobFinance-Mobile Investor Assistant v1.1.2<br></small></small></a>

Is there anything obvious in the above code that means that the items in the feed.txt files would not show? We have checked the cases and locations of the files and they are all correct...
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Postby Jackanape » Sat Jan 13, 2007 5:16 pm

Check your file permissions again. During the switch to the new server, they may have been reset. Failing that, take a look at the forum archives, to see if anyone else has had this problem.
User avatar
Jackanape
 
Posts: 632
Joined: Tue Jan 09, 2007 12:15 am
Location: Capitol of the Great State of New York

Postby Lumberjack » Sat Jan 13, 2007 5:16 pm

I guess you have tried a full news rebuild? Also try <!--#include file instead of virtual to see if you can get that to work.

EDIT: reason I'm thinking a full rebuild is that this could reset file ownership to what it should be on your new server..
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Stmcgill » Sat Jan 13, 2007 5:28 pm

Thanks for the quick answers- file permissions look OK and adding file instead of virtual did not help BUT. The left hand banner on our site is an .html file. When I changed it to .shtml the items showed up but it threw the whole design of the site out?
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Postby Lumberjack » Sat Jan 13, 2007 5:32 pm

Hmm, well then includes are only set for shtml files, not html as well.... there should be a way to fix this, by using a .htaccess file. Look in here for options includes. You'll need some variation of this, I think:
Code: Select all
Options +Includes
AddType text/html shtml
AddHandler server-parsed shtml
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Stmcgill » Sat Jan 13, 2007 5:42 pm

Just checking to see if we even have an .htaccess file:) Any particulart directory? Root I guess.
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Postby SrNupsen » Sat Jan 13, 2007 5:50 pm

.htaccess files have effect on the directory they're in, and in all sub-directories as well. So root is OK.

BUT:

Make sure you don't accidentally overwrite an eventual existing .htaccess file. If the file allready exists, simply append those lines to it.
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway

Postby Stmcgill » Sat Jan 13, 2007 6:06 pm

Thanks- we are playing with one now:)
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Postby Lumberjack » Sat Jan 13, 2007 6:16 pm

From the sounds of it, if you enable includes for the extension .html, you should be fine.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Stmcgill » Sat Jan 13, 2007 6:17 pm

We just put an .htaccess file in root and it screwed the whole site up. Just waiting for a friend to come back to me.
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Postby Lumberjack » Sat Jan 13, 2007 6:51 pm

Oh, that's fun! Erm... you are overriding the server's settings. You want to try to add to them instead. Have a look at this link and be sure you've got everything set right.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Stmcgill » Sat Jan 13, 2007 7:12 pm

Sadly we are with a host so I am also checking with them as to what we are allowed to do. Thanks for the link- reading through it now:)
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Postby Lumberjack » Sat Jan 13, 2007 7:32 pm

Well your host has allowed you to use a .htaccess file to override settings, otherwise it wouldn't have 'worked'. Hopefully you can use it to make html files server-parsed for includes.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Dale Ray » Sat Jan 13, 2007 8:44 pm

Some hosting services don;t like it if you process ALL html files for includes as this increases server load.

Can you post the contents of the .htaccess file you used?

Have you checked your paths?

Also make sure that any CSS files are loading. The directories may have changed and if you load more than one CSS file with the page one coul dbe loading and not the other, so some things look goofy while others don't.
Dale Ray
User avatar
Dale Ray
 
Posts: 1001
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana

Postby Stmcgill » Sun Jan 14, 2007 2:02 pm

Can you post the contents of the .htaccess file you used?


We are not useing one at the moment:)

Have you checked your paths?


Yes

Strangely though the scripts do work if the file is changed to .shtml.

Examples-

This is how it looks now as a .html file-
Image

As you can see it is empty.

This is the left hand banner as an .shtml file-

http://www.clieuk.co.uk/tmpl_navbar_3.shtml

and as you can see the script shows the content as needed.

When I put change the index.shtml file to include the banner as an .shtml it does not include this conent. Yesterday it did but screwed up the layout.

So, in effect the problem has changed and whether I use .html or .shtml it still does not show the conent in our Index page. Could something in our HTML be preventing it showing?

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title><!--#include virtual="/title.txt"--></title>
<link rel="alternate" type="application/rss+xml" title="RSS247" href="http://clieuk.co.uk/rss.xml" />
<link rel="alternate" type="application/rss+xml" title="RSS247" href="http://clieuk.co.uk/mmrss.xml" />
<link rel="stylesheet" type="text/css" href="/site_docs/site_templates/site_template_all/site_common.css" />
</head>

<body bgcolor="FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
<table>
<tr>
<td>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td>
<!--#include virtual="/tmpl_banner.html"-->
</td>
</tr>
</table>
</td>
</tr>
<tr>
<td>

<style type="text/css"><!--F5F5FF-->
<!--
body
{ font-family: Tahoma }
.tborder
{ background-color: #FFFFF1; color: #000000; border: 1px solid #0B198C; }
.cal
{ border: 1px black solid; color: #000000; background-color: #E4E7F5; font-size: 9px }
.calh
{ border: 1px black solid; color: #000000; background-color: #869BBF; font-size: 9px }
.tcat
{ background: #869BBF url(http://clieuk.co.uk/forum/images/gradie ... t_tcat.gif) repeat-x top left; color: #ffffff; font: bold 10pt verdana, geneva, lucida, 'lucida grande', arial, helvetica, sans-serif; }
a:link, a:visited
{ color: #000000; text-decoration: color: #C0C0C0; underline; }
a:hover, a:active
{ color: gray; text-decoration: underline; }
.alt1
{ background-color: #FFFFFF; color: #000000; }
.alt1 img
{ margin:5px; }
-->
</style>

<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr align="left" valign="top">
<td width="163" background="cp_images/pnl_lft_spacer.gif"><!--#include virtual="/tmpl_navbar_3.html"--></td>
<td width="1" background="cp_images/pnl_lft_separation_line.gif"></td>
<td>
<TABLE WIDTH="100%" BORDER="0" CELLSPACING="5" CELLPADDING="0">
<TR><TD>
<!-- EXTERNAL FILE FOR STICKY NEWS WILL BE INSERTED - TO CHANGE THE CONTENT OF STICKY NEWS PLEASE EDIT FILE NAMED tmpl_stickynews2.html -->
<!--#include virtual="/tmpl_stickynews2.html"-->
<!--#include virtual="/news/palmnews.txt"-->
<!-- START of Spacer Box which causes a gap between each news -->
<TABLE WIDTH="100%" HEIGHT="5" BORDER="0" CELLPADDING="0" CELLSPACING="0">
<TR><TD>&nbsp;</TD></TR>
</TABLE>
<!-- END of Spacer Box which causes a gap between each news -->
</TD>
<td valign="top">
<!--#include virtual="/rightnav2.shtml"-->
</td></tr>
</table>
</td></tr>
<tr>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td><!--#include virtual="/tmpl_bottom.html"--></td>
</tr>
</table>
</tr>
</table>
</td></tr>
</table>
</body>
</html>

If I am moving away from a Coranto specific problem here feel free to tell me to shut rp:)
Shaun McGill
www.palm247.com
www.windowsmobile247.com
www.symbian247.com
ALL powered by Coranto
Stmcgill
 
Posts: 16
Joined: Wed Jan 10, 2007 10:18 pm

Next

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests

cron