Unable to use ncategory ?

Is Coranto not working properly for you? Here's where to ask for support help; for best results, follow these steps:
  • - Check your core/addon documentation for possible solutions
  • - Search these forums for similar problems that have already been solved
  • - If you're still stumped, check out THIS TOPIC, and post your question in this forum!!

Moderators: Spunkmeyer, Dale Ray, SrNupsen, Bluetooth, Jackanape

Unable to use ncategory ?

Postby Eurojojo » Tue May 22, 2007 2:48 pm

Hai,

My problem started out in version 1.24 as described in the thread http://www.coranto.org/forum/viewtopic.php?t=271 .

Suddenly, when I added an item it would delete the whole newsdat.txt file... Fortunately there were backups.

I upgraded to version 1.25. The problem persisted. I found out that I have to disable the cra_ncategory.pl script. If I enable it, and try to submit an item, before I get the fillin screen I already get the message:

An error has occurred. The exact description of the error is:
Addon 'cra_ncategory.pl' caused a syntax error when loaded. Disable the addon to prevent this error from recurring. Error: Can't find string terminator "END_SUB" anywhere before EOF at /<linkremoved>/cra_ncategory.pl line 375.Compilation failed in require at craddon.pl line 59.

I read through the pl files and do not see anything wrong. If I disable ncategory I can add an item, however, the item file (I use Maginot) is not created from the template, and newsdat.txt is deleted again. I can upload the backup, do a full rebuild, and the site is working, except for categories, then, of course.

I posted my last item on 9 May. Two weeks later it does not work anymore, without touching the scripts at all.

Any clues?
Eurojojo
 
Posts: 4
Joined: Tue May 22, 2007 1:53 pm
Location: Rotterdam, The Netherlands

Postby Eurojojo » Sat May 26, 2007 1:27 pm

Yes, I am not too scared to admit very stupid mistakes. So you all can solve the same problem in silence if you did the same.

I used my site for temporary storage of a 95 MB ZIP file with photos. And overran the maximum my provider let me have. Therefore the scripts failed. I re-uploaded all .pl files (I did an upgrade to 1.25 while having the heavy load, so those may have not be complete) and now it works again.

:oops:
Eurojojo
 
Posts: 4
Joined: Tue May 22, 2007 1:53 pm
Location: Rotterdam, The Netherlands

Postby Jackanape » Mon May 28, 2007 2:59 pm

d'oh!!!

Glad you got it solved, and thanks for dropping by to share it with the rest of us--as you say, we all need help often!
A human being should be able to change a diaper, plan an invasion, butcher a hog, conn a ship, design a building, write a sonnet, balance accounts, build a wall, set a bone, comfort the dying, take orders, give orders, cooperate, act alone, solve equations, analyze a new problem, pitch manure, program a computer, cook a tasty meal, fight efficiently, die gallantly.
Specialization is for insects.
-Robert A. Heinlein
User avatar
Jackanape
 
Posts: 632
Joined: Tue Jan 09, 2007 12:15 am
Location: Capitol of the Great State of New York


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests

cron