not successful moving newsdat.txt to new server

Is Coranto not working properly for you? Here's where to ask for support help; for best results, follow these steps:
  • - Check your core/addon documentation for possible solutions
  • - Search these forums for similar problems that have already been solved
  • - If you're still stumped, check out THIS TOPIC, and post your question in this forum!!

Moderators: Spunkmeyer, Dale Ray, SrNupsen, Bluetooth, Jackanape

not successful moving newsdat.txt to new server

Postby Stoneage » Mon Mar 19, 2007 4:04 pm

I created a new v1.25 installation on a new server and have copied a newsdat.txt file from an old installation of v1.24 to the new installation.

Although the category names, and profile names I've setup in the new install are identical, when I perform a full rebuild, the old data in the newsdat.txt file is not posted to the individual profile txt files. However, if I submit a new news item, the new data is posted.

Viewing the newsdat.txt all of the old data and new data is there, but for some reason the old data is not being recognized.

In modify news, I can see the original submission date, the category submitted to, and the user, but I can't view any of the other fields for the old data. For the new data, I can view and edit everything.

I should mention that I'm using XMultisubmit addon.

Short of entering all of the old data by hand (which would take hours), I am stuck. Does anyone have any suggestions?

In other words... Help!!!! :(
Stoneage
 
Posts: 52
Joined: Fri Jan 12, 2007 1:07 am
Location: Maine, USA

Postby Spunkmeyer » Mon Mar 19, 2007 5:11 pm

Yeah, editing that by hand would suck.

When you said all the information had been logged by newsdat.txt, did it get logged, or posted to your individual "newsproilename.txt"? or not? And if yes, can you see the data on a page via SSI/PHP includes?

Or, if the data is archived, are those generated and can you include them?
"God Bless the Portable Grassy Knoll"
Spunkmeyer
 
Posts: 69
Joined: Wed Jan 10, 2007 4:36 pm
Location: Whistler, BC, Canada

Postby Stoneage » Mon Mar 19, 2007 5:48 pm

When you said all the information had been logged by newsdat.txt, did it get logged, or posted to your individual "newsproilename.txt"? or not? And if yes, can you see the data on a page via SSI/PHP includes?


Newsdat.txt contains all of the data - the original data and any new entries I create for a given profile. The new entries are added to the top of the newsdat.txt file.

Only the new data is being posted to the individual newsprofilename.txt. Therefore, only the new data is visible via includes.

Full rebuild doesn't solve this, either.
Stoneage
 
Posts: 52
Joined: Fri Jan 12, 2007 1:07 am
Location: Maine, USA

Postby SrNupsen » Mon Mar 19, 2007 6:00 pm

Try and compare one old and one new piece of data (that is, one old and one new line inside newsdat.txt). Does the new one contain any additional information (like, for instance, a string of numbers?)

Have you been using XMultiSubmit all the time?
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway

Postby Stoneage » Mon Mar 19, 2007 7:26 pm

Try and compare one old and one new piece of data (that is, one old and one new line inside newsdat.txt). Does the new one contain any additional information (like, for instance, a string of numbers?)

I think you're on to something!!! Both the old and new entries end in a string of numbers. The new entry has some additional 'x's as well.

Examples:

Code: Select all
OLD - created with old installation
``xelaine``x``xEEVkZkVZVuGbANZUgD``x1152729354``xaccommodations``The XYZ Inn``xRooms and gift shop``x4 Main Street``x``xMachias``xME``x04654``x123-456-7890``x<a href="http://www.badlittlefallsinn.com">http://www.badlittlefallsinn.com</a>``x89191139255573


NEW - created with new installation
``xelaine``x``xEEZuFFpVklkIzDYRlp``x1174330528``xaccommodations``The XYZ Inn``xRooms and gift shop``x4 Main Street``x``xMachias``xME``x04654``123-456-7890``x<a href="http://www.badlittlefallsinn.com">http://www.badlittlefallsinn.com</a>``x94441174223990``x``x``x``x``x``x``x``x``x``x``x``x


If I replace the old number with the new number and the 'x's, the listing will post! I could at this point do a search and replace for the whole document, which will probably solve my problem.

What I don't understand are the additional 'x's in the new listings. It is as if those are empty fields, but in the example shown above, all of the available fields are filled in.

Have you been using XMultiSubmit all the time?

Yes.
Any idea of what is happening here?
Stoneage
 
Posts: 52
Joined: Fri Jan 12, 2007 1:07 am
Location: Maine, USA

Postby SrNupsen » Mon Mar 19, 2007 8:43 pm

This is XMultiSubmit related, for sure. I remember having a similar problem. The string of numbers you see at the end of each line is the XMultiSubmit Profile ID (NOT to be confounded with a normal profile).

My more or less qualified guess (I'm not the author of that addon, and I don't really know any perl) is this:

When you copied only the newsdat.txt file over, and then recreated your Coranto styles and profiles etc., that ID was lost (or, more precisely: A new one was generated when you created your new XMultiSubmit profiles in your new installation). So what's happening now is that new items are filtered out from the profile building news (since the ID doesn't match anymore).

SOLUTION: Back up. Then tell me how many XMultiSubmit Profiles you have. Basically what you have to do is to search for the OLD ID for each profile and replace it with the NEW (current one). Did I lose you yet?


As for the extra ``x occurences at the end of each line, I don't remember where they come from. I had them too, and they are not a problem.
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway

Postby Stoneage » Mon Mar 19, 2007 9:19 pm

This is XMultiSubmit related, for sure. I remember having a similar problem. The string of numbers you see at the end of each line is the XMultiSubmit Profile ID (NOT to be confounded with a normal profile).

That appears to be the case. Thank you so much for pointing that out!

SOLUTION: Back up. Then tell me how many XMultiSubmit Profiles you have. Basically what you have to do is to search for the OLD ID for each profile and replace it with the NEW (current one).

I had only one XMultiSubmit profile. The ID number was the same for all of the categories, so I did a search/replace (replacing the old ID with the new ID) and I now have all of my individual profiles showing data. (What a relief!)

Again... Thank you!
~ Deborah ~
Stoneage
 
Posts: 52
Joined: Fri Jan 12, 2007 1:07 am
Location: Maine, USA

Postby SrNupsen » Mon Mar 19, 2007 10:22 pm

We aim to please 8)
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests

cron