Page 1 of 1

nsettings.cgi suddenly 0 bytes

PostPosted: Wed May 07, 2008 3:32 am
by Dissident
Hi,

I tried to login to coranto today and it wouldn't accept my password. I did a search and found this: http://www.corantodemo.net/wiki/index.p ... stPassword

I went to backup nsettings.cgi and I noticed it had a 0 byte file size. I then tried adding resetpass``xadmin to the blank file, but for some reason I'm not allowed to upload that file/to that directory.

Anyone have any suggestions?

PostPosted: Fri May 09, 2008 6:56 am
by Dissident
Problem has been solved by restoring a backup. It was caused when I was over my storage quota (by a control panel error), and when I tried to login coranto must have tried to save something to nsettings.cgi, was told it was over quota and so a 0 byte file was saved.

PostPosted: Thu Jun 05, 2008 6:21 am
by Sebastian
This seems to be a problem that some Coranto users experience from time to time, including myself. It's not really the end of the world with constant backups.

What's interesting is that you mention your 'storage quota' as the source of the problem due to a control panel error. Personally, I haven't really been able to figure out what the reason is.

Do you (or anybody else) think that there is a general solution to solve this problem from occuring that anybody could try?

PostPosted: Thu Jun 05, 2008 7:30 am
by SrNupsen
Checking with the file system if there's enough available space BEFORE trying to write the file shouldn't really be a problem.

It only takes a coder to do it, and coders are sparse around here :)