Page 1 of 1

First Setup Login After Installation Fails

PostPosted: Tue Feb 26, 2008 10:56 pm
by Kyneburg
I have searched far and wide in this forum and with google search for help with this issue, but have not found any answers as of yet.

After wrestling with (and finally fixing) repeated "500 internal server errors" while attempting to access the coranto.cgi file, my relief at finally making it to the first setup/login page was extremely short lived.

It won't let me in! I type in "setup" (lowercase, no quotes), leave the password blank as directed and all I get is "Login Failure The information you entered is incorrect. Please use your browser's Back button and try again."

And I don't understand why. I followed the instructions very precisely... everything's in ACSII mode, all the CHMODs are in order (I even tried the alternative numbers suggested, and they do nothing either, so I'm keeping them on their original permissions.) I checked with my host provider, and the cgi-bin is in order too, and my absolute paths are confirmed.

I checked the path to perl, " #!/usr/bin/perl" - it's good to go - but whether I add the "-w" or not at the end makes no difference at all. I also tried changing coranto.cgi and viewnews.cgi to .pl files, but that was even worse! (back to the 500 error!) Also, all my error log tells me is a warning about how other users are now allowed to write to the coranto and viewnews files, but that's exactly what I want, right? So, I'm keeping them at CHMOD 755.

I even tried the "reset a lost password" trick by Elvii, but it didn't work either.

I can no longer keep track of how many times I deleted the entire program from my server, and re-uploaded it again, and again. I also downloaded the files from sourceforge twice just to make sure nothing happened at that point in the game, but they are all the same.

I did notice, however, that the Coranto content sourceforge provides does not include the dreaded .htaccess file, so even if I wanted to over-write the one I have in my directory it just couldn't happen. My server actually makes it really difficult for me to see the .htaccess, probably as a precaution. It's hidden in the cpanel file directory tree, and the only reason I could find it was due to my ftp client. I tried downloading a copy and it's permanently hidden from me, on my desktop too. I also tried changing its permissions from CHMOD 644 to any of theothers, from 666 to 755 and 777, but it didn't do anything different for my problem, so I changed it back to 644.

Since I don't know how make a nice neat "thread-link" in this posting, here are the long-hand links to the other most relevant queries on this topic that I found. I have already consulted these, as well as many others about log-in, setup issues, and 500 errors. I have tried the suggestions posted in them to no avail.

They are: ... in+failure ... +1st+login ... ogin+setup

and finally: ... +1st+login

After reading the last post, the only answer I can come up with to find and download an older version of Coranto and be happy with that. Unfortunately, I don't know there there are still any available out there.

Any further suggestions would be GREATLY appreciated. If I cannot find a way to resolve this, I'm just going to have to hunt down alternatives....

My server is linux and I work on a MAC OSX10.3.9

Thanks in advance.

PostPosted: Wed Feb 27, 2008 1:22 am
by Stoneage
Hello, Kyneburg.

I read your post tonight while visiting the Coranto forum. Although I understand your frustration, I don't have an answer for your issue.

I've installed and configured Coranto for at least fifteen different websites, without difficulty. More experienced Coranto folks here may have clues as to what you should check into next when receiving a 500 internal server error, but if it were me (and if I felt confident that the files were all in place with correct permissions), I'd contact my hosting company and request their assistance.


It's worse than just receiving a 500 error

PostPosted: Wed Feb 27, 2008 1:38 am
by Kyneburg
Thanks for your comment, Deborah! It's very nice of you to lend emotional support.

It's not the 500 error that's the problem - I fixed that one thanks to the help of this very forum.... it's the fact that after I type "setup" on the first login screen after installing, even though everything seems in order, I cannot actually begin the setup process. It tells me to press the back button and try again.

I would ask my host provider to help me again if I knew what I could direct them to do for me... they've already checked the cgi-bin, and told me how to access perl scripts, and my absolute directory. Is there something I'm missing?

Thanks again for taking the time to write something encouraging!


PostPosted: Wed Feb 27, 2008 3:40 am
by Jackanape
Hi, Kyneberg, and thanks for your thorough post and complete information regarding your problem! I can't offer a complete solution for you, and I presume you're trying to install 1.25, so here is a link to 1.24b:

I'm not sure there are enough differences between the versions, but I'd be interested in hearing the results!

Good Luck!

Using version 1.24 solves the problem

PostPosted: Wed Feb 27, 2008 7:03 am
by Kyneburg
Hi Jackanape,

Thanks for the link. The older version works fine without a hitch!

I need to get to work putting things all together on my sites now that everything's good to go, but I'll ask my host provider if they can shed some light on what happened with the previous installation asap.

All the best,

PostPosted: Wed Feb 27, 2008 8:04 am
by SrNupsen
Small note: I experience this problem every time I try and install 1.25 - it turned out there is an issue with line ending formats or something (I really can't explain it).

How I solve it: Telnet into the server, open up nsettings.cgi with a text editor (pico/nano/vim/whatever) and resave it. Then reload coranto.cgi in browser.

PostPosted: Wed Feb 27, 2008 1:51 pm
by Jackanape
SrNupsen wrote:Small note: I experience this problem every time I try and install 1.25 - it turned out there is an issue with line ending formats or something (I really can't explain it).

How I solve it: Telnet into the server, open up nsettings.cgi with a text editor (pico/nano/vim/whatever) and resave it. Then reload coranto.cgi in browser.

I didn't know this...could this have something to do with THIS problem:

Nupsen, how should we approach this bug? I can't imagine this happens every time, as I'm sure we would have heard something else before now, no?

To the core of the problem, if it has something to do with line breaks, perhaps THIS topic is related, as well:

PostPosted: Wed Feb 27, 2008 7:40 pm
by SrNupsen
I don't think it's related to the first topic, because Pirate Elf managed to install it before problems started to occur.

Could be related to the second, however. I'm not to savvy about these issues, but I suppose one possible fix would be to upload a new package with proper line endings for nsettings.cgi.

Now if anybody would have the time to do it :lol: