Coranto Dies When SSI is Activated

Is Coranto not working properly for you? Here's where to ask for support help; for best results, follow these steps:
  • - Check your core/addon documentation for possible solutions
  • - Search these forums for similar problems that have already been solved
  • - If you're still stumped, check out THIS TOPIC, and post your question in this forum!!

Moderators: Spunkmeyer, Dale Ray, SrNupsen, Bluetooth, Jackanape

Coranto Dies When SSI is Activated

Postby Jedi Power » Thu Oct 04, 2007 8:31 pm

Hey all,

I am a newbie to Coranto trying to switch over from Cute News so I can use Server Side Includes. I have spent the last couple of days trying to work out the bugs and I am still having a couple of issues.

This issue is I add my .htaccess file with the code for my Include which works great for the information submitted by Coranto and the menus I have created.

The problem is I can not access the Coranto program to Add, Edit, etc. while the .htaccess code is in effect. Any ideas?

Here is the .htaccess code:

Options Indexes FollowSymLinks Includes
AddType application/x-httpd-cgi .cgi
AddType text/x-server-parsed-html .html .htm

Any help would be fantastic! Thanks!
Jedi Power
Galactic Voyage
"You've taken your first step into a larger world"
http://galactic-voyage.com
User avatar
Jedi Power
 
Posts: 7
Joined: Thu Oct 04, 2007 8:12 pm

Postby Dale Ray » Thu Oct 04, 2007 8:49 pm

First what you are doing is making the server parse every file that ends in .html or .htm for SSI. This can increase the load on the server.

If all you want to do is enable SSI try:

Code: Select all
AddType text/html .shtml
AddHandler server-parsed .shtml
Options Indexes FollowSymLinks Includes


Then the files you use SSI in would require the .shtml extension. If almost all of your files are going to use SSI (to include a page header, etc.) then go ahead and have the server process the .html and .htm files.

You only need:

AddType application/x-httpd-cgi .cgi

In a directory where you want .cgi files to be executed.

You will also need to add:

ExecCGI

to the Options line to run scripts in the directory. You will still need proper directory permissions (probably 755).

You may want to try deleting:

FollowSymLinks

If you are not using symbolic links.
Dale Ray
User avatar
Dale Ray
 
Posts: 1004
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana

Postby Jedi Power » Thu Oct 04, 2007 9:00 pm

Thanks for the quick reply! I am just learning SSI and that was the only code I could seem to get to work. Being I am so unfamiliar, what would the code you are talking about look like?
Jedi Power
Galactic Voyage
"You've taken your first step into a larger world"
http://galactic-voyage.com
User avatar
Jedi Power
 
Posts: 7
Joined: Thu Oct 04, 2007 8:12 pm

Postby Dale Ray » Thu Oct 04, 2007 9:14 pm

I would try:

Code: Select all
AddType text/html .shtml
AddType application/x-httpd-cgi .cgi
AddHandler server-parsed .shtml
Options Indexes Includes ExecCGI


If you want to parse .html amd .htm files add those extensions in both lines after the .shtml. Separate the extensions with a space and include the dot (.) before the extension.

You only need:

AddType application/x-httpd-cgi .cgi

and the ExecCGI at the end of the options line if you need to enable CGI for the directory (and all directories under that directory) the .htaccess file is in.
Dale Ray
User avatar
Dale Ray
 
Posts: 1004
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana

Postby Jedi Power » Fri Oct 05, 2007 2:16 pm

My SSI did not work with the code suggested.

AddType text/html .shtml .html .htm
AddType application/x-httpd-cgi .cgi
AddHandler server-parsed .shtml .html .htm
Options Indexes Includes ExecCGI
Jedi Power
Galactic Voyage
"You've taken your first step into a larger world"
http://galactic-voyage.com
User avatar
Jedi Power
 
Posts: 7
Joined: Thu Oct 04, 2007 8:12 pm

Postby Jedi Power » Fri Oct 05, 2007 5:57 pm

I don't know why, but when I took my code and the last line from your code it seemed to work! Here is the final code:

Options Indexes FollowSymLinks Includes
AddType application/x-httpd-cgi .cgi
AddType text/x-server-parsed-html .html .htm
Options Indexes Includes ExecCGI

Any idea why that worked?
Jedi Power
Galactic Voyage
"You've taken your first step into a larger world"
http://galactic-voyage.com
User avatar
Jedi Power
 
Posts: 7
Joined: Thu Oct 04, 2007 8:12 pm

Postby Dale Ray » Fri Oct 05, 2007 8:01 pm

You can reduce the Options line to:

Options Indexes FollowSymLinks Includes ExecCGI

Try it at the top and if that doesn't work at the end. I am not sure if the order makes a difference.

Probably all you needed was the ExecCGI added to the options line.
Dale Ray
User avatar
Dale Ray
 
Posts: 1004
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests

cron