[request] Multipart: upload all files in specified dir.

Post your requests for addons here, and discuss any addons in development here, as well.
Once an addon has completed development, it will be released in the "Addon Release" forum.

Moderator: Spunkmeyer

Postby NitroX_infinity » Mon Aug 02, 2004 7:57 am

I'm not getting this to work :evil:
What do I put in the Upload path of the newsfield?

And XMS has a category per profile so that's okay.
If I give you access to coranto, could you take a look at it for me?
User avatar
NitroX_infinity
 
Posts: 371
Joined: Fri Apr 04, 2003 7:36 pm
Location: The Netherlands

Postby NitroX_infinity » Mon Aug 02, 2004 8:42 am

Well, that didn't work :(
Upload manager itself does see uploaded files but the dropdown box in the newsfield does not.

It seems that the <Field: Category> tag doesn't work in the paths.
I find this most annoying :(
User avatar
NitroX_infinity
 
Posts: 371
Joined: Fri Apr 04, 2003 7:36 pm
Location: The Netherlands

Postby Parahead » Mon Aug 02, 2004 8:49 am

NitroX_infinity wrote:Well, that didn't work :(
Upload manager itself does see uploaded files but the dropdown box in the newsfield does not.

It seems that the <Field: Category> tag doesn't work in the paths.
I find this most annoying :(
I just realized you don´t have the News Category addon installed nor enabled...
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Postby Parahead » Mon Aug 02, 2004 8:54 am

Updated code to handle the scenario where the News Category addon isn´t enabled (altough there really is no point in having <Field: Category> in the upload path if there only is one category):
Code: Select all
$Category = '(default)';
if(!$Category && $CConfig{AddonsLoaded} =~ /(cra_xmultisubmit\.pl)/) {
  my @LockCats = split(/\`\|\`/, $XMS_DB{$profname}->{LockCats});
  $Category = $LockCats[0];
}
$fieldDB{$fn}->{path} =~ s/<Field: (\w+)>/${$1}/gi;
$fieldDB{$fn}->{http} =~ s/<Field: (\w+)>/${$1}/gi;

And like I said before, make sure the directory ../images/(default) exists on the server as well...
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Postby NitroX_infinity » Mon Aug 02, 2004 9:09 am

It works!

Required addons:
XMS
Multipart
News Categories

:P

Thanks again Parahead!
User avatar
NitroX_infinity
 
Posts: 371
Joined: Fri Apr 04, 2003 7:36 pm
Location: The Netherlands

Postby Parahead » Mon Aug 02, 2004 9:15 am

NitroX_infinity wrote:It works!

Required addons:
XMS
Multipart
News Categories

:P

Thanks again Parahead!
You are welcome, the thing that throwed me off was the part with not having the News Categories installed, kind of futile to try and place the images in different Category dirs then... ;-)

Anyway, before this code make it into the next release of Multipart I will update it so it doesn´t break even if the XMS or News Categories addons aren´t installed.
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Previous

Return to Addon Development and Requests

Who is online

Users browsing this forum: No registered users and 2 guests

cron