RSS Feed Help

Discuss news styles, css code, and other Coranto customizations in here...the possibilities are endless, so have at it!

Moderator: Spunkmeyer

RSS Feed Help

Postby Pirate Elf » Fri Mar 16, 2007 11:20 am

Using this walkthrough I managed to get rss feeds working however the link in the feed points to .cgiblahblahblahstyle=&tmpl=viewniews How do I make that point correctly? Thanks as always
Nichts ist für dich
Nichts war für dich
Nichts bleibt für dich
Für immer
Pirate Elf
 
Posts: 732
Joined: Wed Jan 31, 2007 9:45 pm

Postby SrNupsen » Fri Mar 16, 2007 12:28 pm

Post your style here, perhaps? You know, if you tell it blahblahblah, mon ami, then blahblahblah is all you will get.
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway

Postby Musicvid » Fri Mar 16, 2007 3:56 pm

Post your style here, perhaps?
Good idea. Also, it is helpful if you will post a link to your feed so I can see what blahblahblah is all about. Unless there is an error in your $scripturl, if the item links don't point to the right place then something has changed inadvertantly in your style code. If you'll post the style and link, I may be able to help you quickly.
however the link in the feed points to .cgiblahblahblahstyle=&tmpl=viewniews
Also, your template should be 'viewnews,' not 'viewniews.'
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Pirate Elf » Sat Mar 17, 2007 3:00 am

lol! the blahblahblah was supposed to be the random string of numbers that coranto gives the article. What the style was using pulled directly from that link was making it link like this:

.cgi?h2osjdikjsdpjsdfstyle&tmpl=viewnews

I fixed it. Had to revert back to good ole 1.24 because something is very wrong with 1.25 it keeps giving me this long error whenever I edit ANY style. Revert back to 1.24 and edited style so that [admin url] is actually hardcoded to my sites url. Now all works perfectly.
Nichts ist für dich
Nichts war für dich
Nichts bleibt für dich
Für immer
Pirate Elf
 
Posts: 732
Joined: Wed Jan 31, 2007 9:45 pm

Postby Musicvid » Sat Mar 17, 2007 3:58 am

JFYI PirateElf,

The RSS 2.0 Style and Template I wrote were designed to work with Coranto Beta 1.31.5, and I made no pretense or attempt whatsoever to make them compatible with any of the Coranto 1.2x release versions. The topic and thread you found my solution under should have made that stipulation entirely self-evident.

If you got it working on 1.2x, then congratulations, it would be nice to hear how you did it. However, I am willing to offer support for the RSS 2.0 Template/Style only when used with 1.3x.x as is clearly stated in the forum thread title.

If you are interested in RSS solutions for versions 1.25 and below, I encourage you to work with one of the three addons that were specifically written for that purpose. I have decided against trying to make my solution backwards-compatible, since there has been so much research and development done on the part of Dale Ray and others towards that end.

I hope you will take note that my post was made under
Coranto -- The Official Site Forum Index -> Coranto 2.0 Development -> RSS and 1.31.5
for a reason (several, actually)!

Many thanks to Dale Ray and others for their continuing development of RSS solutions for 1.2x, since it appears it will still be some time before a release version of 1.3x/2.0 is available.
----------------------------------------
Apples are apples.
Oranges are oranges.
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Pirate Elf » Sat Mar 17, 2007 10:24 am

the addons seem broken. Dale's leaves a
Code: Select all
<br>
near the end of the xml file which does not work and causes errors. To make your trick work with 1.24 at least (AS I said 1.25 is broken for me and gives way way too many errors when editing styles as I use a few custom subs) just follow your instructions and grab the addon that changes the filename after building (can't remember the name off hand) and change the file to xml and then just build news.

For myself I had to hard code my url into where the link says
Code: Select all
admin url
then it was just one more rebuild and works like a charm.
Nichts ist für dich
Nichts war für dich
Nichts bleibt für dich
Für immer
Pirate Elf
 
Posts: 732
Joined: Wed Jan 31, 2007 9:45 pm

Postby Lumberjack » Mon Apr 02, 2007 2:25 pm

PirateElf wrote:I fixed it. Had to revert back to good ole 1.24 because something is very wrong with 1.25 it keeps giving me this long error whenever I edit ANY style.


We are aware of this error, but I am not sure of the problem and I don't think anyone else has looked. Why haven't you made a post about this in the development forum? Bug reports are important..
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby SrNupsen » Mon Apr 02, 2007 9:52 pm

Problem with syntax errors when editing certain types of styles fixed in this thread.
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway

Postby Lumberjack » Tue Apr 03, 2007 9:51 am

Oh yes, my bad.. good job finding the problem.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Spunkmeyer » Wed Apr 04, 2007 4:00 pm

If you're having problems with v1.25, download SrNupsen's version of cradmin.pl from http://www.dusj.no/filer/cradmin.pl, and upload that instead of the one in the zip. That will fix your style issues.. and will save you looking through the post. I accidentally posted this without seeing his message :/
"God Bless the Portable Grassy Knoll"
Spunkmeyer
 
Posts: 69
Joined: Wed Jan 10, 2007 4:36 pm
Location: Whistler, BC, Canada


Return to Customization

Who is online

Users browsing this forum: No registered users and 3 guests

cron