v1.31.5 Discussion

All notes and input on 2.0 Development are herein. <ul><li>Feature requests</li>
<li>Bug Reports</li>
<li>Beta Testing Feedback</li>
<li>Open Dev Discussion</li></ul>

Moderator: Coranto Moderator Team

v1.31.5 Discussion

Postby Lumberjack » Fri Jan 12, 2007 9:03 pm

Figured this was also necessary. So, first snag, I am not sure what needs to be done to get a fresh install of this working. What needs to be chmod'd to what? And, does coranto really have to sit at the top of cgi-bin?
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Jackanape » Fri Jan 12, 2007 9:08 pm

Parahead made a lot of changes to the directory structure, as I understand, so I'm not sure...you'll need to check with the forum archives here, or with him personally.

I'm glad you're already looking at that dev release, Jack, it's good to get a leg up on it...
User avatar
Jackanape
 
Posts: 632
Joined: Tue Jan 09, 2007 12:15 am
Location: Capitol of the Great State of New York

Postby Lumberjack » Fri Jan 12, 2007 9:13 pm

It seems the way forward... looks like there are a lot of new features and a much better structure to the filing, I'm looking forward to getting it running..
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Parahead » Fri Jan 12, 2007 9:15 pm

Lumberjack wrote:So, first snag, I am not sure what needs to be done to get a fresh install of this working. What needs to be chmod'd to what?
There shouldn't be so many snags, have you tried running the installtion? Please state which problems you have run into more specifically if that is the case...

Jackanape wrote:Parahead made a lot of changes to the directory structure, as I understand, so I'm not sure...
If you do a fresh installation, the new directory structure isn't so much to wory about. If upgrading from 1.24 there is an upgrade feature which will automatically move addons and stuff into its new locations. Please read the included documentation, try and install and *then* come back with specific questions... Heck, I am a coder which tries to write documentation but if no one reads it, really depressing... ;-)

Jackanape wrote:I'm glad you're already looking at that dev release, Jack, it's good to get a leg up on it...
I am also glad for that! :-)
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Postby Lumberjack » Fri Jan 12, 2007 9:18 pm

OK so I read the documentation again... the setup instructions are the same as the old one I think. It might just be me (just getting up and running on macosx so I'm still getting the feel of it) but I think my files are all chmod'd as coranto 1.2.4. I just get an error 500.. ok leave it with me, I'm just being lazy! I'll have it running soon.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Parahead » Fri Jan 12, 2007 9:26 pm

Lumberjack wrote:OK so I read the documentation again... the setup instructions are the same as the old one I think.
Yes, that is correct, but the actual setup process is changed to be (hopefully) more fool proof with some additional tests of things...

Lumberjack wrote:I just get an error 500..
Well, that can be anything;
http://www.parahead.com/coranto_doc.sht ... oranto_Doc
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Postby Lumberjack » Fri Jan 12, 2007 9:32 pm

Hmm... error logs... ok it looks like the problem with the stable release which was that apache2 wasn't configured correctly :D believe me when I say I won't sleep until I get this working (I know its sad)
Ah! First discovery.. a simple script that should have run without problems had to be resaved, evidently mac can't read the "DOS format". No doubt something to do with newlines. I'll check your files..
EDIT: ok, I lied. I can't seem to find the problem, and I'm going to sleep!
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Lumberjack » Sat Jan 13, 2007 3:16 pm

Ok, finally thought I'd just try to chmod 777 everything, and that seemed to work. I like the crlog.txt, very nice and could be very useful. Yes there are some nice features :)
One thing I noticed: when initially loading the script, the menu section is not visible. It becomes visible when clicking the link Main Page though. You see this Parahead?
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Lumberjack » Sat Jan 13, 2007 3:21 pm

Second note: Facelift does a nice tick-to-activate feature on the addon manager page (and that is all arranged in the one-line format). This should be on the to-do list for the dev release. At least to make that page fit in with the "Option Pages Layout" setting.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Lumberjack » Sat Jan 13, 2007 4:17 pm

About addons: the new format for documentation (good idea) is to use DOC 2, but this doesn't work for me. I have checked against ncategory and I don't see what I have done differently. I'll see if I can find that sub in the core..

EDIT: weird, putting in the link by hand seems to bring it up. So it is the code that puts the link in addon manager that is not working quite properly..
Code: Select all
coranto.cgi?session=cckidakitczzndEbwe&x=23&addon=timezone&action=admin&adminarea=addondoc2

I tested it by replacing ncategory in the url after clicking the docs link for that addon.

EDIT2: fixed problem by changing line 1724 of cradmin.pl from this:
Code: Select all
         if ($$afi{$i}->{'DOC'} eq '2') {

To this:
Code: Select all
         if ($$afi{$i}->{'DOC'} == 2) {

But I don't understand why it worked for News Categories but not for TimeZone :?
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Lumberjack » Sat Jan 13, 2007 7:50 pm

Noticed that when addon has #! DOC 0, Addon Manager page showed Documentation Available, but no doc link. Fixed by changing line 1714 of cradmin.pl from this:
Code: Select all
         $description .= "&nbsp;<b>" . CRgetmsg('Documentation Available') . "</b> " if $$afi{$i}->{'DOC'};

To this:
Code: Select all
         $description .= "&nbsp;<b>" . CRgetmsg('Documentation Available') . "</b> " if $$afi{$i}->{'DOC'} > 0;
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby Parahead » Sun Jan 14, 2007 9:10 am

I found a personal TODO-file for the planned 1.31.6, just wanted to share them with you Lumberjack so you could look into them:

* It says "abbrevated" instead of "abbreviated" i crlang.pl

* Change so that a filelock isn't involved when *reading* of nsettings.cgi (causes problems for some addons, EasyEdit for example).
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Postby Lumberjack » Sun Jan 14, 2007 12:19 pm

The spelling error is an easy fix, but the filelock will take some thinking about on my part. I'll add these to the Dev Release topic.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK

Postby SuperCarla » Sun Feb 25, 2007 1:40 am

Lumberjack wrote:Ok, finally thought I'd just try to chmod 777 everything, and that seemed to work.


probably you could have solved your problem by chmod 777 the arc folder inside the data folder - which btw also need to be 777

at least that was what finally did the trick for me after trying to install 1.31.5 like 10 times om 3 different servers

the setup documentation truly needs an update

/tina
Lost it
SuperCarla
 
Posts: 30
Joined: Fri Feb 23, 2007 3:07 pm
Location: Djursland, Denmark

Postby Lumberjack » Sun Apr 01, 2007 11:18 am

If you have more insight into setup documentation, can you suggest how to update it?
EDIT: oh, my chmod problems stem from having a different owner of the files than the server runs under. If I update the owner to be www then I think the server is happy to run things with more restrictive permissions.
Lumberjack
 
Posts: 555
Joined: Wed Jan 10, 2007 7:22 pm
Location: Oxford, UK


Return to Coranto 2.0 Development

Who is online

Users browsing this forum: No registered users and 3 guests

cron